彩神排列三_神彩排列三官方

Eclipse的maven项目自动重置jdk版本的问题

时间:2020-01-04 13:28:23 出处:彩神排列三_神彩排列三官方

eclipse上创建maven项目,随着调用jar的扩大,必须修改pom.xml文件

也不我点击保存,也不我update project进行更新。

我发现,告诉我为那先 ,我明明将eclipse上你你這個项目的build path上边的jre修改成了1.8版本的,也不我假如update project就会变回1.5

问题图片描述如下:

有有有一个多多普通的maven项目



你看一遍红色的叉叉,有报错

报错内容如下所示

JAX-RS (REST Web Services) 2.0 requires Java 1.6 or newer.

Java compiler level does not match the version of the installed Java project facet.

大伙看一遍java版本有问题图片,好多好多 有查看一下啦

都必须看的很清楚,我本地的java版本是1.8,eclipse配置的默认jre也是你你這個版本



也不我查看本地eclipse默认compiler版本,也是1.8



既然eclipse的配置的jre和jdk的版本都没人问题图片,没人大伙看看当时人的maven项目版本是否也是那我 呢?



查看项目的build path



妈蛋,你以为是1.5

改它



将它改成了我本地的1.8,我去刷新一下





进行maven的project update

更新也不我,再次查看项目的build path



很你要生气,又变回去了。

正确处理问题图片的辦法 也不我,注意到maven update project的也不我提到update project configuration from pom.xml

也也不我肯定和pom.xml你你這個文件有关



为pom.xml添加配置jdk版本的说说

也不我按照提示update project



问题图片就正确处理了。

热门

热门标签